Can’t boot from USB on Gigabyte Motherboard : gigabyte

Fix Boot Issues “Gigabyte Motherboard” | Fix Boot Device Not Found

Can’t boot from USB on Gigabyte Motherboard : gigabyte

I am trying to move from linux mint to windows 10 with a USB flash drive. I have windows on my flash drive, but when I go to the BIOS menu, there is no option to boot from USB, even when I dont have a USB plugged in. How do I boot from USB? If I could get an answer Id be very grateful.

Enable USB Boot in Gigabyte Motherboard

Gigabyte Motherboard GA-P35-DS3L (rev. 2.0) uses AWARD BIOS which is usually quite good. I updated my BIOS sometime back and never had any issues since. However, I suspect during that BIOS update, it must’ve reset settings to safe-boot mode or similar which wipes out some of the config’s I had there. After much testing and reboots, following settings always seems to work for both Windows and Linux Live USB Boot in Gigabyte Motherboard.

Interestingly, this seems to be an ever growing issue for many different motherboards from different vendors. I went through almost all of the posts available in Google and Gigabyte website, but it seems there wasn’t any good solutions out there. Most people end up using a CD/DVD, but for me, I want to use USB Boot in Gigabyte Motherboard to make my installations faster. I can’t be bothered to install and re-install and burn CD/DVD every time I want to wipe my disks clean. Mostly, I am not good at keeping CD/DVD’s in a nice stacked and numbered order to be able to find them later on, I’m messy, so there you have it!

I’ve got this Gigabyte Motherboard GA-P35-DS3L (rev. 2.0) in my old desktop running Q6600 Quad Code CPU and 4GB RAM. I’ve used this computer for last 5 years and to be honest, it’s still superb compared to some newer machines I’ve used recently. I installed Windows 7 and Kali Linux on it and after almost 2 years I decided it’s time to reformat and re-install everything from scratch. Easier said than done. I put a USB disk with Windows 7 on it and rebooted. My Gigabyte motherboard doesn’t detect it Live USB! I can honestly say, it did last time I tried. Naturally, I thought, I must’ve messed up my Live Windows 7 USB stick. So, I tried Linux (Kali Linux, Ubuntu, Arch .. you name it), still Gigabyte motherboard doesn’t detect any of the Live USB’s. I so started looking to motherboard to figure out how to enable USB boot in Gigabyte Motherboard.

Leave a Comment